rake aborted! You have already activated rake 0.9.2, but your Gemfile requires rake 0.8.7. Consider using bundle exec.


rake aborted!
You have already activated rake 0.9.2, but your Gemfile requires rake 0.8.7. Consider using bundle exec.

(See full trace by running task with –trace)

Solution:

1. Include below rake version in your gemfile

“gem ‘rake’, ‘0.9.2’ ”

2. Open rake file and include below line above ==>require ‘rake’

require ‘rake/dsl_definition’

3.In same rake file add below code above ==>app_name::Application.load_tasks

module ::app_name
class Application
include Rake::DSL
end
end

module ::RakeFileUtils
extend Rake::FileUtilsExt
end

make sure app_name will be your application name, just copy  app_name from ” app_name::Application.load_tasks”

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s